Magics issue

Dear all,

Recently, I'm getting errors when running my toolbox plotting scripts.

It seems to be something related to MAGICS package.

It is weird because they worked fine before.

Anyone had the same problem ?

Thanks in advance.

I'm having the same issue. When I try to run any of the example applications in ignore-cache mode I get the following error message.

Traceback (most recent call last):
  File "/opt/cdstoolbox/cdscompute/cdscompute/cdshandlers/services/", line 58, in handle_request
    result = proc(context, *context.args, **context.kwargs)
  File "/opt/cdstoolbox/cdscompute/cdscompute/", line 114, in __call__
    return p(*args, **kwargs)
  File "/opt/cdstoolbox/cdscompute/cdscompute/", line 59, in __call__
    return self.proc(context, *args, **kwargs)
  File "/home/cds/cdsservices/services/", line 536, in plot_xnetcdf
    return CDFPlotter().plot(*args, **kwargs)
  File "/home/cds/cdsservices/services/", line 394, in plot
  File "/usr/local/lib/python3.6/site-packages/Magics/", line 776, in _plot
  File "/usr/local/lib/python3.6/site-packages/Magics/", line 177, in wrapped
    raise MagicsError(err)
Magics.Magics.MagicsError: Magics Error - No Plot Produced!!! (-1892571959)

Exactly !
But now it seems it was already solved (wink)
Thank you for your reply.