UserError: Restricted access to ERA5T. Please, check that that your date selection is valid


There seems to have been some change in how ERA5T data requests are processed. In short, CDS requests that used to run smoothly now fail with "UserError: Restricted access to ERA5T. Please, check that that your date selection is valid." Has this change been implemented accidentally or is this a restriction that one has to work with going forward?

In detail: Since I am not aware of an API that gives information regarding available timestamps (let alone which timestamps are ERA5 and ERA5T), I used to periodically query a time series at a single pixel for e.g. the last few days. It's meant to be a lightweight process that finds out for which timestamps data exists. E.g.:

{ "area": "0.1/-0.1/-0.1/0.1", "day": [ "24", "25", "26", "27", "28", "29", "30", "31" ], "format": "grib", "month": [ "05" ], "product_type": "reanalysis", "time": [ "00:00", "01:00", "02:00", "03:00", "04:00", "05:00", "06:00", "07:00", "08:00", "09:00", "10:00", "11:00", "12:00", "13:00", "14:00", "15:00", "16:00", "17:00", "18:00", "19:00", "20:00", "21:00", "22:00", "23:00" ], "variable": "2m_temperature", "year": [ "2022" ] }

Now (I'm writing this on 5/31/2022; around 6pm UTC), the above suddenly fails. I suspect this is due to the query looking for data e.g. on 05/31, 05/30, .... Sadly, it's not even clear what valid timestamps are. UTC "now" - 5 days (which is what is described here) MARS access restrictions#era5tRestrictedaccesstoERA5T would mean that only 2022/05/26 18:00 Z is available. At the same time the web interface suggests that 2022/05/26 21:00 Z is available.

So to repeat my question:

  • Is the above access restriction now permanent?
  • Will there be an API to learn what timestamps are available and whether the data is ERA5/ERA5T?


Johannes Schmude

Hello Johannes, 
I'm currently having the same issue. Did you manage to solve it?

Me too, would like to know what's going on here.

I have now created a JIRA support issue at ECMWF.

Do you have the link to this ticket so that I can follow the investigation as well?
Thanks a lot

Not sure you have access:

It's in status "Waiting for Support" now.

I don't have access indeed, please keep us posted on the outcome of the ticket


there is currently an investigation going on regarding the way the embargo period is applied to the latest ERA5T data. 

However it is unlikely that there will be updates until sometime next week.

Thanks Michela,
I'm still conducting some tests and it seems that even older data is not available anymore (even 5 days delay).


we seem to have the same issue, is there any updates on this?

Current status of my ticket is this:

Dear Marco,

Thank you for your enquiry to ECMWF Support.

As my colleague Michela posted on the C3S Forum, there is currently an ongoing investigation about the way the embargo period is applied to the latest ERA5T data. 

Unfortunately, due to the Jubilee holiday, it is not likely that we will be able to provide updates on this issue until next week.

We apologise for the inconvenience this may cause in the meantime.

Kind regards,


ECMWF Support
Support Portal | C3S Forum| C3S Knowledge Base 

Okay, thanks!

Dear Michela,

Thanks so much for keeping track of these issues. Is there any update on this?


As today, there still seem to be a problem and I get "UserError: Restricted access to ERA5T" with the following request in 'reanalysis-era5-single-levels' :


        'time'    : '12:00',

        'day'     : ['01','02','03','04','05','06','07','08','09','10','11','12','13','14','15',


        'month'   : '06',

        'year'    : '2022',

        'nocache' : '47512',

        'variable': ['sea_ice_cover','sea_surface_temperature']

We have been getting the same error when fetching wind data more recent than the 22nd of May:

Open request form

Request ID: fe6751f6-8f18-4d2c-9493-5785f6d6ba54
Product type:
100m u-component of wind, 10m u-component of wind
00:00, 01:00, 02:00, 03:00, 04:00, 05:00, 06:00, 07:00, 08:00, 09:00, 10:00, 11:00, 12:00, 13:00, 14:00, 15:00, 16:00, 17:00, 18:00, 19:00, 20:00, 21:00
Sub-region extraction:
North 54°, West 2°, South 51°, East 6°

Show error details

The request you have submitted is not valid

Reason: Mars server task finished in error; UserError: Restricted access to ERA5T. Please, check that your date selection is valid. For more information, visit [mars]; Error code is -2; Request failed; Some errors reported (last error -2)

I'm also getting this error for the request:

{ "area": [8, -75, -40, -35],
"day": "04",
"format": "netcdf",
"month": "06",
"product_type": "reanalysis",
"time": ["00:00", "01:00", "02:00", "03:00", "04:00", "05:00", "06:00", "07:00", "08:00", "09:00", "10:00", "11:00",
  "12:00", "13:00", "14:00", "15:00", "16:00", "17:00", "18:00", "19:00", "20:00", "21:00", "22:00", "23:00"],
"variable": [
  "total_precipitation" ],
"year": "2022" }

Is there any update on the issue?

There could be more than one issue here. If your API script attempts to retrieve say 31/04/2022 or 31/06/2022 which does not exist, then while in the past this would return no data anyway (i.e. no data returned on 31/04 or 31/06), since some changes were implemented last week, it would appear that if the data does not exist, the retrieval fails over with the error UserError: Restricted access to ERA5T (misleading I would say). 

Of course for those of you who are trying to retrieve whatever ERA5 data is available, this means that your API scripts no longer work at this point in time. You could try modifying your scripts to test this and share your results here.

Do you know of a smart way to see what timestamps are available? Because the way that the API call is now structured, you always submit all 24 hours under "time" to download one or multiple full days, but then the request will fail when the most recent day does not have all 24 hours available.

Hello Anabelle,

Is it planned to bring back the old way that when requesting a whole month of data it would still work, but provide only the latest available data for the requested month? This was the easiest option to download all the available latest data for the current month. As an example if we want to download all the data available for june 2022 without having to specify the specific days, the following request would have worked previously :




        'time'    : '12:00',

        'day'     : ['01','02','03','04','05','06','07','08','09','10','11','12','13','14','15',


        'month'   : '06',

        'year'    : '2022',

        'variable': ['sea_ice_cover','sea_surface_temperature']


, but it won't work anymore with the error message "UserError: Restricted access to ERA5T". Requesting the whole current month was the easiest way to quickly get the very latest available data.

Thank you very much.

Dear Michela et al,

Is there any update on this issue and/or its anticipated resolution date? I'm encountering this issue with my ETL for various ERA5 datasets.